Skip to content

CB Radio Simulator Software Updated

I finally got some issues sorted out with PayPal integration on my RadioMods site, I had been meaning to fix that for about a year!

Realising that I also needed to update my software I spent some time doing that, so it now has updated registration links as well as some new links to this site and my YouTube channel built into its menu system.

The software is on my S&M Software Site

How to fix OS X Installer Failure "No packages were eligible for install. Contact the software manufacturer for assistance"

If you ever get this error while attempting to install OS X, you will likely need to set the date using terminal.

The simplest way to set it (if you have no OS installed on the machine) is to boot the install media, open the terminal and check the date (type date).

The following information was found on someones site (sorry I forget which), but I have included it here to make it easier to correct this issue.

Use the following command in terminal to set the machine to a time and date of your choosing:
date {month}{day}{hour}{minute}{year}

For example, to set it to 8pm on the 2nd October 2018

date 100220002018

The command below will output the current date in a format suitable for use on another machine:
date "+%m%d%H%M%Y.%S"

Further, the following (mouthful of a command) will let you specify a date and time in a more readable format and set it in one go:
date -f "%Y-%m-%d %H:%M:%S" "2016-07-09 15:20:10"

Fix No Entry (not permitted) on boot from USB drive Mac OS X

I have come across this issue a few times, and always forget what causes it.

If you have a bootable USB flash drive with an OSX installer on it, but it fails to boot showing a not permitted icon this means that it found a boot partition and system to boot from, BUT it could not boot from it, this could be due to it being an incompatible system or more likely, a permissions error.

I have seen lots of good, and bad advice online about this issue, and NOWHERE does it mention the fix I found, so I thought I would document this to help people out.

Mount the USB drive on another mac computer and do a "Get Info", at the bottom it shows the Name of users and "everyone" and what read&write permissions they have for the drive, click the padlock to allow changes, and then change the permission for all users (especially "everyone") to be read&write instead of only "read", make sure "Ignore Ownership on this volume" is checked, then click the padlock to save it and close the window, eject the USB drive and it should now work (if you build the volume correctly in the first place).

High Voltage Leakage/Breakdown Voltage Tester Project

I have finished (mostly) the leakage tester project, the final video is scheduled to go live on Saturday morning.

I had a couple of weird issues I had to resolve, I was seeing skewed voltage and current readings at higher levels. The zener diodes that I was using to clamp the inputs of the Arduino as protection were turning on too soon and starting to clamp, effectively changing the resistor divider ratios, I ended up removing the voltage sensing ones, and changing the current sensing one to a 6.2V instead.

The final design will need avalanche diodes, probably 5.6V rated.

I picked up a new (to me) computer.

I just purchased a 2010 Mac Pro to replace my 2008 Mac Pro (which I had upgraded with a pair of 3.2GHz CPU’s), the machine looks the same outside, but on the inside is a lot better suited to doing videos.

I transferred the various cards into the new machine, and the SSD etc.

The new machine transcodes video in half the time of the old machine, so it was worth the effort and expense.

I did a 46 minutes long test video on both machines, the old machine transcoded it in 65 minutes 15 seconds, the new machine did it in 32 minutes 40 seconds!

The new machine has dual 6 core, 2.93GHz CPU’s, with the possibility of upgrading it with 3.46GHz versions.

I’m visiting Australia, and met Dave!

I am currently visiting Australia.

I spent several days roaming around the Gold Coast with my wife, then we flew down to Sydney today and dropped by the EEVBlog lab and spent a few hours chatting with Dave.

Dave was kind enough to run me through his production process and even bought us lunch!

It was great to be able to meet Dave and we had some good conversations.

Whilst we were there Dave recorded a video on a calculator I had gifted him, it will be interesting to see the final edited video when he publishes it.

The ability to drop by the lab and spend so much time chatting was especially appreciated as Dave was still getting over being ill.

We drove over the harbour bridge on the way to our Airbnb, I got some video whilst we drove over, it is smaller than it looks!

My new links site.

I have finally found the time to sit down and make a short url conversion site.

This now allows me to create my own short URL's and also ensures that they will work forever, giving me permanent control of the short URL links.

defs.link


Mac Pro (Early 2008) Not Starting Up.

I had to work on my dads Mac Pro today as it wouldn't turn on, he was panicking a bit as he had work which he had to do on it (he is a typesetter and printer).

Symptoms were a rapid flashing power LED (approx 1 pulse per second), no startup chime, no screen coming on.

I diagnosed it down to a bad DIMM module, after a lot of swapping modules I was able to determine which one it was.

The modules are installed in pairs, so it had to lose 4GB of ram as they are 2GB modules, fortunately it had 12GB installed (4x1GB and 4x2GB) and he doesn't use it for anything that requires all of the ram anyway, so 8GB will be OK for the time being until I get OWC to send a replacement.

I purchased the modules as a set of 4 in 2013 from OWC, and they have a "lifetime warranty", we shall see if they follow through with it !

I am back in my house, sort of.

I am sort of back in my house, I am in the process of moving everything back in, and trying to set up my lab, which includes re-organising how it is setup.

There are still things that the builders haven't finished, such as the kitchen! they haven't shown up for two weeks so far... to do a days work to finish it.

My flooring is now being done

My house is almost ready to move back into, I installed a new ranch slider the other day (after the builders failed to show up).

I then had to buy and install new skirting and door trims so the painter could finish his work (again the builders failed to show up to do the work they missed, see a theme here?)

Now my flooring is being laid, so if all goes to
plan I will be able to move back in within the week.

Live streams

I recently did some live streaming on my YouTube channel, they always seem to go on longer than I planned, I was intending to only stream for about an hour each time, but they seem to stretch out to a few hours at times.

Had some good chats with people and got some tips for my new 3D printer, which was great.

I also did some diagnostic work on the HP4261A LCR meter, manage to narrow the fault right down, and fixed it later on that evening (videos will be published for it soon).

Fluke 5200A AC Calibrator Update

I have been working on the fluke some more, I have been going through its basic calibration procedure (doing a video it of course).

I can see that TP5 on the oscillator control board is noisy, so this could be a clue to where the noise is originating.

As it is a closed loop system, I will need to inject my own signal at some point of the circuit to see if the noise is before or after that point.

My house is finally being fixed

So my house which was flooded on January 5th has finally started to have work done to repair it.

House has been gutted, now I just have to wait whilst it is fixed.